1999 toyota vista ardeo
1999 toyota vista ardeo
1999 toyota vista ardeo
1999 toyota vista ardeo
1999 toyota vista ardeo
More photos Toyota Vista Ardeo

1999 Toyota Vista Ardeo engine cut off when in low speed problems

Report a Problem

Date:August 10, 2011, 6:51 pm
Name:william lungu
Location:Zambia, kitwe
Vehicle:Toyota Vista Ardeo
Year:1999
Problems:am experiencing engine cuts when am driving in low speed, i have changed the fuel filter, and cleaned the fuel line but its even worse now, what the next move
Previous car:toyota mark 11 grand
Contact:show contact

Suggest a Solution


August 21, 2014, 5:13 am  from: shepherd mutare zimbabwe
I am alarmed that you have not received any response to the problem of engine cuts.iam experiencing the same problem with my ardeo.Did you finally get a solution that we could share?
regards

shepherd
Contact: show contact
September 25, 2014, 3:07 pm  from: kamugasa robert
I had the same problem of engine cuts at low speed, but it is when I had installed a car alarm. now after removing alarm no engine cuts at low speed....
Contact: show contact
April 20, 2015, 9:01 pm  from: Anthony Muriithi
changed plugs bt there is this noise resulting to low power and a black smoke ocassionaly when reving.
Contact: show contact
November 12, 2016, 10:09 am  from: nddanji kapungwe
I have the same problem with my vista please I need your help ,+260973548482
Contact: show contact

Suggest a Solution

 * - The field should be filled
* Your Name:
 Contact (e-mail, phone...):
* Comments:
Photos: