1998 toyota vista ardeo
1998 toyota vista ardeo
1998 toyota vista ardeo
1998 toyota vista ardeo
1998 toyota vista ardeo
More photos Toyota Vista Ardeo

1998 Toyota Vista Ardeo fuel cutting in low speed problems

Report a Problem

Date:July 16, 2010, 5:35 am
Name:Harrison
Location:Zambia, Lusaka, Herndon
Vehicle:Toyota Vista Ardeo
Year:1998
Problems:the car is japan import D4 system the engine just stops in low speed.

Suggest a Solution


August 20, 2010, 8:27 am  from: MSM
i have the same car and it used to have the same problem. all you need to do is take for major service, thus any Toyota garage. you also need to clean / replace the tank fuel filter and clean the fuel line system. another thing might be you need to adjust accelarater cable, so that your rpm is above 750.
Contact: show contact
September 14, 2010, 11:43 am  from: STANCILAY MATIZANADZO
I have a 2001 model toyota vista automatic,when driving the engine just cutts off .I cleaned the fuel filter in the tank and checked all lines for proper connections,but the problem is still there .And itis writting ECONON on the dashboard .Please help.
Contact: show contact
October 4, 2010, 12:35 pm  from: Humphrey
The eco on means fuel economy is on
Contact: show contact
October 12, 2010, 5:38 am  from: Sami
I have a 2001 model toyota vista automatic,when driving the engine just cutts off .I cleaned the fuel filter in the tank and checked all lines for proper connections,but the problem is still there .And itis writting ECONON on the dashboard .Please help.---------

Hi I have a 1999 model and had the same problem. i removed the Thermostat and it's now ok. but you need to do regular service and check the fuel you use. avoid leaded fuel and preferably use "light" fuel

Sam
Contact: show contact
October 19, 2010, 4:50 pm  from: david mwanza
its not the thermostat, its the fuel filter get it from toyota zambia, do not be cheated had the same problem and hey all is well now.
Contact: show contact
October 27, 2010, 11:53 am  from: Kingfred Mwansa Mubinde
I have the same problem with my car Vista Ardeo, it cuts in low speed or when you get the smell of sulphur like, the car will just stop.Advise
Contact: show contact
February 24, 2011, 2:17 am  from: Jairo Arends
I have that same problem with my car. The thing is that because it's imported from Japan and it's RHD, the local toyota garage wont service it, because of some stupid policy. I will have to do this on my own. So can anyone help me out how to get to the fuel filter?
Contact: show contact
March 9, 2011, 1:45 pm  from: Gilbert Kafunga
I have a 1998 model toyota vista sv50 automatic,when driving the engine just cutts off .I cleaned the fuel filter in the tank and checked all lines for proper connections,but the problem is still there .And itis writting ECONON on the dashboard The engine .Please help.---------
Contact: show contact
June 14, 2011, 7:50 pm  from: KAU
I have a 1999 Vista Sedan D4. I've been driving it for a year now without changing the fuel filter- I just can't locate it. My mechanic has tried checking the fuel tank but still couldn't find it. Is it that he didn't check hard enough or it's located some place else?
August 10, 2011, 6:42 pm  from: william lungu
i have a vista 1999 model, the engine cuts when in low speed advise, i have tried cleaning the fuel tank, fuel filter buts its still doing the same
Contact: show contact
September 8, 2011, 9:05 am  from: Baaska
Hey Kau take the back seats tank locates bottom of the back seats good luck!
Contact: show contact
September 8, 2011, 9:08 am  from: Baaska
I have a same problem in Mongolia Hey guys check your engine oil and smell it if smell is like a petrol it means d4 is losing petrol to engine oil and you should change d4 it is very important.
Contact: show contact
October 23, 2011, 5:33 pm  from: Richard balama
pleas how and where can i find the photo of where the different sensor connected in a car toyota vista ardeo 3s fe d4.
Contact: show contact
July 11, 2013, 7:09 pm  from: Welly
hi,i own a vista 1998 now at 5900km in 2011 clocking 30000km mileage.but the car now cuts and jerks when at low speed and i smell something like sulphur.i have cleaned the tank and changed the fuel filter thrice now.pliz help
Contact: show contact
July 16, 2013, 10:25 am  from: Aubrey Gulumba
i am looking for a D 4 for Toyota vista 1999 model. Where can i find because here in Malawi our shops dont have spare parts for this car
Contact: show contact
August 26, 2013, 8:27 am  from: mwenya pule
this engine is some how complicated but not tht bad to duel with,the only problem is with th sensors of the fuel system .when u use bad fuel it senses,duty in th fuel it senses,slight change in temperature it also do the same and what we should now is its not mechanical but electronic and some of us we know 3s engines be 4 with out a d4 provion(it is a clean engine)
Contact: show contact
September 9, 2013, 10:38 am  from: Toko Draneb
I also experienced the same problem with my Vista Ardeo, VVTi 1.8cc, 1999. It used to cuts power in low speed or on Humps but rectified by changing the oil Pump & PK.
Contact: show contact
February 4, 2014, 3:03 pm  from: Chiwazu
iam also experiencing the same problem,the enjine just cuts off anytime when iam driving,i changed oil,oil filter but we failed to locate the fuel filter again, how can i solve these problems please help i really need the car.
February 4, 2014, 3:09 pm  from: Chiwazu
please help me where is the fuel filter located
Contact: show contact
February 6, 2014, 8:12 am  from: chief
Hie guys can someone tell me the fuel consumption rate of a Vista Aedio .Also can some one advise me if it is a good car please help before i buy.
Contact: show contact
March 24, 2014, 10:56 pm  from: Peter dube
My toyota vista vvti failed to make the next start after 30 minutes from the last start. When i turn the key to start position everything on the dashboard dims off as if something is taking a lot of current.
Contact: show contact
August 2, 2014, 6:33 pm  from: Aslam
cold start for 12 minutes i changed engine oil/ plugs/ cleaned the tank + fuel fltr/ coolant 3 time still no change/ So i tuned by myslf coz i was tired ov going to garage and now jst 1 kick am on the road and she does 16 to 17 km per liter. I like ma visita. Try
Contact: show contact
August 17, 2014, 10:42 pm  from: Kishan
I also ha sthe same problem...my car will get start but the initial RPM was just 500 so the engine will gets cut off....i filled the tank with 97
octane â??super unleadedâ?? and now lokks OK....
September 8, 2014, 8:21 pm  from: lawson
i have a problem too, when ever i start my toyota vista,it will run for 1 minute and the engine check light goes on then the car shuts off....PLZ HELP
Contact: show contact
February 18, 2015, 2:19 pm  from: Abraham Chol Marial
I have a toyota Vista Ardeo 1998 model, when i started my engine, it can idle as it supposed to be and can also cut off when driving. what could be solution, please help me for i take it for any unknown repair.
Contact: show contact
September 28, 2015, 1:00 pm  from: Francis Chinyanta
I have a 1998 model Toyota vista automatic,when driving the engine just cuts off and fuel finishes fast.when driving Accelerator becomes too hard until after some few kilometers it increases the speed
Contact: show contact
June 23, 2016, 7:07 am  from: Ishmael Nanavat
I can see that most of your problems are very common.. The only thing that is giving you guys a problem is the oxygen sensor.. If u find the engine check light coming on even when the engine is running then, know that u just to replace it without doubt.. AV DONE THAT ON MOST THE D4 ENGINES AND MY CUSTOMERS HAVE NEVER COME BACK AGAIN..
Contact: show contact
August 19, 2016, 7:00 pm  from: symo
i have a 1998 sv50 visita with a D4 engine, sometimes the engine stops when im driving,and attimes there is a letter M on the dashboard above the D [driving option] that brinks when im driving, any help please?
Contact: show contact
November 22, 2016, 4:09 pm  from: maguta
hie guys i have the toyota vista ardeo d4 fuel consumption is very high is travelling 8km per litre and now the engine check light is on and when yu apply emergency brakes it jus cut off and ther follows a hard starting please help
Contact: show contact
May 18, 2017, 5:00 pm  from: levy manda
My fuel gange is not working
Contact: show contact
May 20, 2017, 5:10 am  from: samakayi G from Zambia
I have a Toyota Vista D4 3S engine 1999 model when you drive for about 100kms the just stops on its on especially on humps.when it stops you wait for sometime the engine to cool down,once it cools down it starts without problems. The engine check light it has been on for about a year now.Please help is it the fuel pump? but i do not let the fuel to go below half tank. i have been with this car for more 4 yrs now.plz help
Contact: show contact
September 6, 2017, 7:28 pm  from: Stanley Chanda
My toyota vista d4 just cuts off and won't start after about 10kilometers drive,, only starts after it cools off.. Changed plugs but nothing. Help please
Contact: show contact
March 6, 2018, 8:57 am  from: AARON
Hi.. I HAVE THE SAME PROBLEM WITH MY VISTA
HOW DO I SOLVE THE MATTER IT JERKS @ LOW SPEED

PLS ADVISE

THANKS
Contact: show contact
June 8, 2018, 6:56 am  from: Chali
Am having a problem with My Vista d4 it will only start when you press the gas pedal
Contact: show contact

Suggest a Solution

 * - The field should be filled
* Your Name:
 Contact (e-mail, phone...):
* Comments:
Photos: