1999 suzuki alto
More photos Suzuki Alto

1999 Suzuki Alto does this car have a crankshaft position sensor problems

Report a Problem

Date:May 16, 2012, 6:31 am
Name:Kennedy Mavhumashava
Location:Zimbabwe, Bulawayo
Vehicle:Suzuki Alto
Year:1999
Problems:The car switches the engine off after a continuous drive of 50km and more, if i put on the headlights as I drive. A diagnosis said the crankshaft position sensor has a problem. however, someone tells me that this car does not have that sensor. so please advise me on this. Thanks

Suggest a Solution


July 7, 2012, 1:22 pm  from: Ncube creedence
The crankshaft sensor is there jus attached to the engine bt you need to lmport it
Contact: show contact
July 21, 2012, 3:16 am  from: sunil
yes it has a crank sensor it is located near the alternator u would see it if u remove the alternator.
Contact: show contact
October 4, 2012, 9:03 am  from: alfred
I have a Suzuki Alta date of manufacture 1999. Surprisingly when |swith on the engine steering wheel turns to the left. When driving car most of the time veers to the left hand side.
Contact: show contact
October 4, 2012, 9:03 am  from: alfred bajada
I have a Suzuki Alta date of manufacture 1999. Surprisingly when |swith on the engine steering wheel turns to the left. When driving car most of the time veers to the left hand side.
Contact: show contact
May 3, 2013, 1:15 am  from: kusal thapa
crankshaft main dia,C.R dia and piston size of toyota land cruiser Q-LJ78W-PGT
Contact: show contact

Suggest a Solution

 * - The field should be filled
* Your Name:
 Contact (e-mail, phone...):
* Comments:
Photos: