2002 opel corsa
2002 opel corsa
2002 opel corsa
2002 opel corsa
2002 opel corsa
More photos Opel Corsa

2002 Opel Corsa car problem in SA

Report a Problem

Date:July 21, 2011, 5:48 pm
Name:justin
Location:SA, Gauteng
Vehicle:Opel Corsa
Year:2002
Problems:drive for about 50km, then when i accelerate there is no power. when i take my foot off the accelerator then power restores. wot can the fault be.
it only does it when the outside temperature is above 21degrees.

Suggest a Solution


October 8, 2011, 11:34 pm  from: david maull
Similar problem with my Mercedes. The fault may lie with the mass airflow sensor in the air intake (after the airfilter). Try very carefully cleaning it with electronic cleaner (the sensor wire is very delicate). If that improved things then the chances are that the sensor needs replacing. Shop around.
The original manufacturers branded part is probably available as an OEM part.
Contact: show contact
October 8, 2011, 11:36 pm  from: david maull
Similar problem with my Mercedes. The fault may lie with the mass airflow sensor in the air intake (after the airfilter). Try very carefully cleaning it with electronic cleaner (the sensor wire is very delicate). If that improved things then the chances are that the sensor needs replacing. Shop around.
The original manufacturers branded part is probably available as an OEM part.
Contact: show contact

Suggest a Solution

 * - The field should be filled
* Your Name:
 Contact (e-mail, phone...):
* Comments:
Photos: